Your interactive trading laboratory!
 • 
22 users online

1 MINUTE CANDLE

I need to backtest using 1 minute candle, but when I set in the Model Settings--> Data Scale --> 1 minute, when I see the backtest result it is daily candle, how can I trade using 1 minute candle?

Attachment

Cancel

Responses

Hi Matteo,

Are you running the latest build (Q215)? There were some issues around data scale in a previous build. If so, make sure you have 1 minute scale selected in Model Settings and you have a Historical Data Source configured that can supply intraday data. For example, I've enabled AlphaVantage here which provides 1-minute intraday data.

Hi Matteo, Are you running the latest build (Q215)? There were some issues around data scale in a previous build. If so, make sure you have 1 minute scale selected in Model Settings **and** you have a Historical Data Source configured that can supply intraday data. For example, I've enabled AlphaVantage here which provides 1-minute intraday data.

I have now enabled AlphaVantage, I have tried with 5 minute candle many times, but the charts and the positions are always daily.

I have now enabled AlphaVantage, I have tried with 5 minute candle many times, but the charts and the positions are always daily.

Hi Matteo, I see the issue. The QPremium dynamic universes (like the S&P 500 you selected) are tied to QPremium data, which is daily only. We have a release coming up soon and will make some changes in the UI to clarify this when these universes are selected.

Hi Matteo, I see the issue. The QPremium dynamic universes (like the S&P 500 you selected) are tied to QPremium data, which is daily only. We have a release coming up soon and will make some changes in the UI to clarify this when these universes are selected.

I don't know how to solve this problem, I have tried to create a universe using AlphaVantage with 10 stocks(AAPL ALLK AMZN BMA BYND EBAY GOOG JPM LK TSLA ) it works fine till I set the data scale lower than a day, the error message I get is: "Error during Backtest: Object reference not set to an instance of an object". This is a recurrent error that i get.

I don't know how to solve this problem, I have tried to create a universe using AlphaVantage with 10 stocks(AAPL ALLK AMZN BMA BYND EBAY GOOG JPM LK TSLA ) it works fine till I set the data scale lower than a day, the error message I get is: "Error during Backtest: Object reference not set to an instance of an object". This is a recurrent error that i get.

Hey Matteo, I'm not able to duplicate that, it could be something related to your Model perhaps? Please send an email to info@quantacula.com and we can troubleshoot.

Hey Matteo, I'm not able to duplicate that, it could be something related to your Model perhaps? Please send an email to info@quantacula.com and we can troubleshoot.

Q216 should be released later today with the following warning when you select an incompatible universe/scale combination:

Q216 should be released later today with the following warning when you select an incompatible universe/scale combination:

Your help is really appreciated, I have written to you an e-mail.

Your help is really appreciated, I have written to you an e-mail.

Hi Matteo, there were a couple of issues.

  1. The benchmark should be specified as a symbol, for example SPY instead of S&P 500
  2. Alphavantage does not provide that much intraday data, so your requested range could not return any intraday data.

When the benchmark symbol fails to load, it produced the admittedly cryptic error which we will improve in the next release.

Try running this with benchmark SPY and date range of most recent 1 year and it should work.

Hi Matteo, there were a couple of issues. 1. The benchmark should be specified as a symbol, for example **SPY** instead of **S&P 500** 2. Alphavantage does not provide that much intraday data, so your requested range could not return any intraday data. When the benchmark symbol fails to load, it produced the admittedly cryptic error which we will improve in the next release. Try running this with benchmark **SPY** and date range of **most recent 1 year** and it should work.

Thank you so much, now I can backtest using 1 minute candle!!! Unfortunately AlphaVantage provides 1 minute data, but only for the current month, I don't know if there is something to enable to get older data or if there are other better historical data source. With that being said thank you very much anyway!

Thank you so much, now I can backtest using 1 minute candle!!! Unfortunately AlphaVantage provides 1 minute data, but only for the current month, I don't know if there is something to enable to get older data or if there are other better historical data source. With that being said thank you very much anyway!

IQFeed offers historical intraday data, but it's a subscription. If you find any other data provider you're interested in let us know and we can build an adapter!

IQFeed offers historical intraday data, but it's a subscription. If you find any other data provider you're interested in let us know and we can build an adapter!

When using 1-2 weeks data range comes this error, what does it mean?

When using 1-2 weeks data range comes this error, what does it mean?

It's an error in the "Periodic Returns" Model Result Viewer. Likely because there was not enough intraday data to populate the viewer. We can implement a fix so the error does not occur, but if you click OK it should have no impact on the rest of the results or operation of QS.

It's an error in the "Periodic Returns" Model Result Viewer. Likely because there was not enough intraday data to populate the viewer. We can implement a fix so the error does not occur, but if you click OK it should have no impact on the rest of the results or operation of QS.
Forum Tips

Please sign in if you want to participate in our forum.

Our forum uses Markdown syntax to format posts.

To embed code snippets, enclose them in [CODE][/CODE] tags.